Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
problem with testing ohnet-suite after compiling it (FreeBSD)
17-02-2018, 10:40 AM (This post was last modified: 17-02-2018 10:41 AM by airflow.)
Post: #3
RE: problem with testing ohnet-suite after compiling it (FreeBSD)
(15-01-2018 01:51 PM)simonc Wrote:  I think the error in is caused by failing to specify a target platform in the command line to make. For FreeBSD, this should be something like

make all nocpp11=yes freebsd=1

Can you try doing a build only in this way to see if that works?

The normal way to run automated tests would be via, specifying the target platform on the command line. I can't remember having support for FreeBSD here, can't find any support in current code and can't see any support in the file's history. If we have managed to lose the support, you'd need to add support for a --freebsd option and have that add nocpp11=yes freebsd=1 to the command line passed to make.

If you get something working, I'm happy to integrate a patch.

I just looked into this again, using the newest version of the ohnet-code from github. When I try doing a build with "make all nocpp11=yes freebsd=1", like you suggested, it completes without any errors and it looks good, the libraries are generated. This is exactly how I compiled ohnet for FreeBSD in the past, which worked fine.

We had to do a few small adaptions to the code of ohnet to make it compatible to FreeBSD some time ago. You incorporated these changes into the official code. This is documented in this post:

I use the ohnet-lib together with MinimServer on FreeBSD. Since recently, if I use the fresh compiled lib with this program, it crashes without any helpful error-message:

root@services_2:/usr/local/share # minimserver/bin/startc
MinimServer 0.8.4 update 114, Copyright (c) 2012-2017 Simon Nash. All rights reserved.
Abort trap

This is why I wanted to look into the testing-suite of ohnet to find out if the lib is working properly. The testing-suite definitely worked in the past. I only had to change the variable buildCmd from "make" to "gmake". Only now after a while it stops and asks for specifying --system (like in the error-message given in my initial post). This is in spite of the fact that it compiles seemingly without any problems with the command above.

I'm sorry that I'm not able to provide any patches to fix this (I would if I could), but if can point out any ideas what I could try, I would gladly to this.

Attached File(s)
.txt  ohnet-freebsd-compile.txt (Size: 29.6 KB / Downloads: 1)
Find all posts by this user

Messages In This Thread
RE: problem with testing ohnet-suite after compiling it (FreeBSD) - airflow - 17-02-2018 10:40 AM

Forum Jump: