Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
ohNet Installtion
05-02-2013, 12:01 PM (This post was last modified: 05-02-2013 12:15 PM by andreww.)
Post: #11
RE: ohNet Installtion
That NuGet error is familiar. Looking at my notes, that is due to a bug/missing feature in Mono. I have noted that it occurs in Mono 2.10.5 and is fixed by Mono 2.10.9. I believe Debian still uses Mono 2.10.8, and we have had quite a lot of problems with Mono versions that old. NuGet in particular seems to be terrible for using cutting-edge .NET features that are buggy or unimplemented in Mono.

A workaround is to run "go fetch" on a Windows machine. All of the dependencies fetched by NuGet are platform-independent, so you can fetch them on a Windows machine and copy them across to your Pi.
Reading your post again, I think you probably won't get much benefit from ohOS. ohNet handles UPnP while ohSongcast handles the Songcast protocol. Neither needs or benefits from ohOS. Where you might eventually find some benefit in ohOS is if you want to provide a web-based configuration UI for your device, or if you want to install/uninstall apps remotely, but I would not recommend worrying about that to begin with, and our documentation here isn't great. You are probably better off using ohNet and ohSongcast on their own. (Someone else might be able to tell you more about how to use ohSongcast. I think some work might still need to be done to separate the re-usable networking components from the Windows/Mac device drivers.)
Visit this user's website Find all posts by this user


Messages In This Thread
ohNet Installtion - steve - 04-02-2013, 04:26 PM
RE: ohNet Installtion - simonc - 04-02-2013, 04:40 PM
RE: ohNet Installtion - steve - 04-02-2013, 04:48 PM
RE: ohNet Installtion - simonc - 04-02-2013, 05:10 PM
RE: ohNet Installtion - steve - 04-02-2013, 05:20 PM
RE: ohNet Installtion - steve - 04-02-2013, 06:42 PM
RE: ohNet Installtion - simonc - 04-02-2013, 08:05 PM
RE: ohNet Installtion - steve - 05-02-2013, 09:15 AM
RE: ohNet Installtion - andreww - 05-02-2013, 11:20 AM
RE: ohNet Installtion - steve - 05-02-2013, 11:48 AM
RE: ohNet Installtion - andreww - 05-02-2013 12:01 PM
RE: ohNet Installtion - steve - 05-02-2013, 12:59 PM
RE: ohNet Installtion - steve - 05-02-2013, 03:43 PM
RE: ohNet Installtion - simonc - 05-02-2013, 04:34 PM
RE: ohNet Installtion - andreww - 05-02-2013, 04:56 PM
RE: ohNet Installtion - steve - 05-02-2013, 05:17 PM
RE: ohNet Installtion - steve - 05-02-2013, 10:09 PM
RE: ohNet Installtion - andreww - 06-02-2013, 09:55 AM
RE: ohNet Installtion - steve - 06-02-2013, 12:09 PM
RE: ohNet Installtion - simonc - 06-02-2013, 12:14 PM
RE: ohNet Installtion - simonc - 06-02-2013, 01:28 PM
RE: ohNet Installtion - steve - 06-02-2013, 12:21 PM
RE: ohNet Installtion - steve - 06-02-2013, 01:48 PM

Forum Jump: