Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Raspbian Headless
03-02-2016, 07:12 AM
Post: #11
RE: Raspbian Headless
You sure you did checkout the headless version?

Just to make sure please run:

```

make uninstall
make clean
git checkout raspbian-headless
make raspbian DISABLE_GTK=y
make raspbian-install
```
Find all posts by this user
03-02-2016, 07:51 AM (This post was last modified: 03-02-2016 07:51 AM by axelk.)
Post: #12
RE: Raspbian Headless
(03-02-2016 07:12 AM)DoomHammer Wrote:  You sure you did checkout the headless version?

Just to make sure please run:

```

make uninstall
make clean
git checkout raspbian-headless
make raspbian DISABLE_GTK=y
make raspbian-install
```


I think I did it that way.
Here is my command history (some dirt removed) if there is something wrong let me know:

474 git clone https://github.com/DoomHammer/ohPlayer/t...ess-player
475 git clone https://github.com/DoomHammer/ohPlayer.git
477 cd ohPlayer/
479 ./go fetch --all
480 apt-get install gcc-4.8 g++-4.8
481 update-alternatives --install /usr/bin/gcc gcc /usr/bin/gcc-4.6 20
482 update-alternatives --install /usr/bin/gcc gcc /usr/bin/gcc-4.8 50
483 update-alternatives --install /usr/bin/g++ g++ /usr/bin/g++-4.6 20
484 update-alternatives --install /usr/bin/g++ g++ /usr/bin/g++-4.8 50
485 apt-get install gtk+-3-dev libnotify-dev notify-osd libasound2-dev
486 apt-get install ruby-dev
487 gem install fpm
492 apt-get install rubygems
494 gem install fpm
495 cd linux/
497 make raspbian DISABLE_GTK=y
498 make raspbian-install
499 openhome-player

//gtk error here//


Axel
Find all posts by this user
03-02-2016, 07:53 AM
Post: #13
RE: Raspbian Headless
Could you enter ohPlayer directory and run the command I provided in the previous post?

In the meanwhile I will see if I can provide binary packages for this.
Find all posts by this user
03-02-2016, 08:05 AM
Post: #14
RE: Raspbian Headless
(03-02-2016 07:53 AM)DoomHammer Wrote:  Could you enter ohPlayer directory and run the command I provided in the previous post?

In the meanwhile I will see if I can provide binary packages for this.

Ok. I see that I do not get the headless version of the code. So this is a git usage problem I think. I am not very familiar with it.

git clone https://github.com/DoomHammer/ohPlayer.git
.. does not get me the headless code. Not sure what I am doing wrong.


thanks, Axel
Find all posts by this user
03-02-2016, 08:17 AM
Post: #15
RE: Raspbian Headless
You are not doing anything wrong Smile I just forgot to add that you have to explicitly switch branches after cloning. This is not integrated into master yet hence the need to checkout.

If OpenHome reviews it and deems it fit, the additional steps won't be needed.
Find all posts by this user
03-02-2016, 08:41 AM (This post was last modified: 03-02-2016 08:56 AM by axelk.)
Post: #16
RE: Raspbian Headless
(03-02-2016 08:17 AM)DoomHammer Wrote:  You are not doing anything wrong Smile I just forgot to add that you have to explicitly switch branches after cloning. This is not integrated into master yet hence the need to checkout.

If OpenHome reviews it and deems it fit, the additional steps won't be needed.

got it compiled now Smile The "git checkout headless-player" command did only work properly after a fresh cloning of ohPlayer :
574 git clone https://github.com/DoomHammer/ohPlayer.git
575 cd ohPlayer/
578 git checkout headless-player
585 ./go fetch --all
586 cd linux
587 make raspbian DISABLE_GTK=y
588 make raspbian-install



<s>but Cool
axelk@pa2 ~ $ openhome-player
Using Subnet 192.168.0.0
Volume Control Unavailable
terminate called after throwing an instance of 'OpenHome::AssertionFailed'
Aborted</s>

Naaa.
root@pa2:~# adduser axelk audio
Adding user `axelk' to group `audio' ...
Adding user axelk to group audio
Done.

axelk@pa2 ~ $ openhome-player
Using Subnet 192.168.0.0
Volume Control Unavailable
ZoneHandler. SenderZone is PiPlayer-pa2
OHM SENDER DRIVER LATENCY 150
OhmSender::RunMulticast wait
OhmSender::RunUnicast wait
OHM SENDER DRIVER ENABLED 1
ZoneHandler::Run received presetinfo
OHU sender running on 192.168.0.25:40777
OhmSender::RunUnicast go
ZoneHandler::TimerZoneUriExpired 3
ZoneHandler::TimerZoneUriExpired count=3, uri=ohu://192.168.0.25:40777
ConfigAppBase::ConfigAppBase iResourcePrefix: Softplayer
Pipeline state change: buffering
Pipeline state change: buffering
Pipeline report property: MODE {mode=null; supportsLatency=0; realTime=1; supportsNext=0; supportsPrev=0}
Pipeline state change: stopped
Pipeline report property: TRACK {uri=; mode=null; trackId=1; startOfStream=1}
NEW SOURCE: Playlist


Success ! Heart

I have a minim server running in the network and the raspberry pi 2 has a hifiberry digi+ installed.


many thanks for the help,
Axel
Find all posts by this user
03-02-2016, 04:44 PM
Post: #17
RE: Raspbian Headless + mp3
not sure if this is related to the use of the headless code. But I am not able to play mp3 files. Flac is working fine but mp3 files are not recognized.


- I compiled it in these two ways but no mp3 playing:
a) make raspbian DISABLE_GTK=y
b) make raspbian DISABLE_GTK=y USE_LIBAVCODEC=0


- This is logged by the openhome-player:
Pipeline report property: MODE {mode=Playlist; supportsLatency=0; realTime=0; supportsNext=1; supportsPrev=1}
Pipeline report property: TRACK {uri=http://192.168.0.8:9790/minimserver/*/Syn3/11NEW/No*20More*20-*20-*20Suicide*20Commando.mp3; mode=Playlist; trackId=3; startOfStream=1}
Pipeline report property: METATEXT {}
Failed to recognise audio format (iStreamStopped=0, iExpectedFlushId=0), flushing stream...

Axel
Find all posts by this user
04-02-2016, 12:56 PM
Post: #18
RE: Raspbian Headless
(31-01-2016 09:29 AM)DoomHammer Wrote:  Hi gals and guys,

Anybody willing to test-drive a headless version is more than welcome. I made my branch here: https://github.com/DoomHammer/ohPlayer/t...ess-player and compilation instructions differ in that you have to append `DISABLE_GTK=y` to your `make` invocation.

Cheers,
Piotr
DoomHammer,

Could you please post step by step instructions how to install your headless player? You could post it on GitHub perhaps.

I keep on getting error messages and I know I am doing some things wrong, but have no idea what I am doing wrong.

Thanks, Guus
Find all posts by this user
09-02-2016, 08:04 AM
Post: #19
RE: Raspbian Headless
Hi, sorry for the delayed response.

As for the lack of MP3 playback you can edit `OptionalFeatures.h` to turn some features on and off. I have no idea why MP3 and AAC are turned off by default (licensing reasons?).

@axelk: Good that FLAC works in your headless install and cheers for Suicide Commando. I thought it was the band at first, not the track Wink

@gussie: I don't want to modify the README since I would like my fork to be as close as possible to the original. So the instructions should be in my opinion (on RPi):

```
git clone https://github.com/DoomHammer/ohPlayer.git
cd ohPlayer
git checkout headless-player
./go fetch --all
cd linux
# You may edit OptionalFeatures.h at this point
make raspbian DISABLE_GTK=y
make raspbian-install
```

Could you post the error messages you are getting?
Find all posts by this user
09-02-2016, 09:40 AM
Post: #20
RE: Raspbian Headless
(09-02-2016 08:04 AM)DoomHammer Wrote:  As for the lack of MP3 playback you can edit `OptionalFeatures.h` to turn some features on and off. I have no idea why MP3 and AAC are turned off by default (licensing reasons?).

So easy and it works Smile
Thanks!

Axel
Find all posts by this user


Forum Jump: