Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Raspbian Headless
13-07-2016, 06:13 AM
Post: #31
RE: Raspbian Headless
(12-07-2016 06:06 PM)cdr Wrote:  Has this support been released yet?

What exactly do you mean by that?
Find all posts by this user
22-08-2016, 09:09 PM
Post: #32
RE: Raspbian Headless
So I got the latest version running on a fresh jessie SD card.

Once installed, you type the following at the prompt (I didn't see any instructions anywhere):

openhome-player

Can somebody provide instructions on how to start the mediaplayer at boot?

I can enter my TuneIn account (when I click TuneIn in Kazoo).

Konfig sees the player but there don't seem to be any configurable options there.

Thanks for your input.

Guus
Find all posts by this user
23-08-2016, 07:23 AM
Post: #33
RE: Raspbian Headless
(22-08-2016 09:09 PM)guussie Wrote:  So I got the latest version running on a fresh jessie SD card.

Once installed, you type the following at the prompt (I didn't see any instructions anywhere):

openhome-player

Can somebody provide instructions on how to start the mediaplayer at boot?

I can enter my TuneIn account (when I click TuneIn in Kazoo).

Konfig sees the player but there don't seem to be any configurable options there.

Thanks for your input.

Guus

this is how I managed to get openhome started after a reboot on debian/raspbian jessie:

pi@raspberrypi:~ $ cat /etc/systemd/system/oh.service
[Unit]
Description=OpenHome Player
After=network.target

[Service]
User=pi
ExecStart=-/usr/bin/openhome-player > /dev/null 2>&1
# ExecStart=/etc/init.d/ohplayer start
# ExecStop=/etc/init.d/ohplayer stop
Restart=on-failure

[Install]
WantedBy=multi-user.target
Alias=openhomeplayer.service

// load/init service
pi@raspberrypi:~ $ sudo systemctl daemon-reload
// start service
pi@raspberrypi:~ $ sudo systemctl start oh.service
// enable service to survive reboot
pi@raspberrypi:~ $ sudo systemctl enable oh.service
// current state
pi@raspberrypi:~ $ sudo systemctl status oh.service
● oh.service - OpenHome Player
Loaded: loaded (/etc/systemd/system/oh.service; enabled)
Active: active (running) since Fri 2016-07-01 11:11:08 CEST; 6min ago
Main PID: 718 (openhome-player)
CGroup: /system.slice/oh.service
└─718 /usr/bin/openhome-player > /dev/null 2>&1


Axel
Find all posts by this user
23-08-2016, 08:02 AM
Post: #34
RE: Raspbian Headless
(23-08-2016 07:23 AM)axelk Wrote:  
(22-08-2016 09:09 PM)guussie Wrote:  Can somebody provide instructions on how to start the mediaplayer at boot?

this is how I managed to get openhome started after a reboot on debian/raspbian jessie:

pi@raspberrypi:~ $ cat /etc/systemd/system/oh.service
[Unit]
Description=OpenHome Player
After=network.target

[Service]
User=pi
ExecStart=-/usr/bin/openhome-player > /dev/null 2>&1
# ExecStart=/etc/init.d/ohplayer start
# ExecStop=/etc/init.d/ohplayer stop
Restart=on-failure

[Install]
WantedBy=multi-user.target
Alias=openhomeplayer.service

// load/init service
pi@raspberrypi:~ $ sudo systemctl daemon-reload
// start service
pi@raspberrypi:~ $ sudo systemctl start oh.service
// enable service to survive reboot
pi@raspberrypi:~ $ sudo systemctl enable oh.service
// current state
pi@raspberrypi:~ $ sudo systemctl status oh.service
● oh.service - OpenHome Player
Loaded: loaded (/etc/systemd/system/oh.service; enabled)
Active: active (running) since Fri 2016-07-01 11:11:08 CEST; 6min ago
Main PID: 718 (openhome-player)
CGroup: /system.slice/oh.service
└─718 /usr/bin/openhome-player > /dev/null 2>&1


Axel

Thanks Alex, very useful. However, it doesn't work for me, yet. I get the following error code:

pi@openhome:~ $ sudo systemctl status oh.service
● oh.service - OpenHome Player
Loaded: loaded (/etc/systemd/system/oh.service; enabled)
Active: inactive (dead) since Tue 2016-08-23 07:54:54 UTC; 1min 6s ago
Process: 428 ExecStart=/usr/bin/openhome-player > /dev/null 2>&1 (code=exited, status=1/FAILURE)
Main PID: 428 (code=exited, status=1/FAILURE)

Aug 23 07:54:52 openhome systemd[1]: Started OpenHome Player.
Aug 23 07:54:54 openhome openhome-player[428]: openhome-player [subnet address]


I have no ohplayer in /etc/init.d

Could that be the reason?

Thanks, Guus
Find all posts by this user
23-08-2016, 08:29 AM
Post: #35
RE: Raspbian Headless
> I have no ohplayer in /etc/init.d
>
> Could that be the reason?
no, there is no file needed in /etc/init.d. The start is handled by systemd.

Are you able to start openhome as user 'pi' ?
What is returned when you do this ?

Things which are prohibiting the openhome-player start are user pi is not in the audio group (to access the audio device). And my DAC must be turned on and ready to receive the audio stream.

pi@pa2 ~ $ grep audio /etc/group
audio:x:29Tonguei,axelk



This is how it looks on my pi when I start oh-p manually:

pi@pa2 ~ $ /usr/bin/openhome-player
Using Subnet 192.168.0.0
ZoneHandler. SenderZone is PiPlayer-pa2
OHM SENDER DRIVER LATENCY 150
OhmSender::RunMulticast wait
OhmSender::RunUnicast wait
OHM SENDER DRIVER ENABLED 1
OHU sender running on 192.168.0.25:48275
ZoneHandler::Run received presetinfo
OhmSender::RunUnicast go
ZoneHandler::TimerZoneUriExpired 3
ZoneHandler::TimerZoneUriExpired count=3, uri=ohu://192.168.0.25:48275
ConfigAppBase::ConfigAppBase iResourcePrefix: Softplayer
Pipeline state change: buffering
Pipeline state change: buffering
Pipeline report property: MODE {mode=null; supportsLatency=0; realTime=1; supportsNext=0; supportsPrev=0}
Pipeline report property: TRACK {uri=; mode=null; trackId=1; startOfStream=1}
Pipeline state change: stopped
NEW SOURCE: Playlist
ZoneHandler::Run received presetinfo
ZoneHandler::TimerZoneUriExpired 2
ZoneHandler::TimerZoneUriExpired count=2, uri=ohu://192.168.0.25:48275
ZoneHandler::Run received presetinfo
ZoneHandler::TimerZoneUriExpired 1
ZoneHandler::TimerZoneUriExpired count=1, uri=ohu://192.168.0.25:48275



Axel
Find all posts by this user
23-08-2016, 09:53 AM
Post: #36
RE: Raspbian Headless
(23-08-2016 08:29 AM)axelk Wrote:  > I have no ohplayer in /etc/init.d
>
> Could that be the reason?
no, there is no file needed in /etc/init.d. The start is handled by systemd.

Are you able to start openhome as user 'pi' ?
What is returned when you do this ?

Things which are prohibiting the openhome-player start are user pi is not in the audio group (to access the audio device). And my DAC must be turned on and ready to receive the audio stream.

pi@pa2 ~ $ grep audio /etc/group
audio:x:29Tonguei,axelk



This is how it looks on my pi when I start oh-p manually:

pi@pa2 ~ $ /usr/bin/openhome-player
Using Subnet 192.168.0.0
ZoneHandler. SenderZone is PiPlayer-pa2
OHM SENDER DRIVER LATENCY 150
OhmSender::RunMulticast wait
OhmSender::RunUnicast wait
OHM SENDER DRIVER ENABLED 1
OHU sender running on 192.168.0.25:48275
ZoneHandler::Run received presetinfo
OhmSender::RunUnicast go
ZoneHandler::TimerZoneUriExpired 3
ZoneHandler::TimerZoneUriExpired count=3, uri=ohu://192.168.0.25:48275
ConfigAppBase::ConfigAppBase iResourcePrefix: Softplayer
Pipeline state change: buffering
Pipeline state change: buffering
Pipeline report property: MODE {mode=null; supportsLatency=0; realTime=1; supportsNext=0; supportsPrev=0}
Pipeline report property: TRACK {uri=; mode=null; trackId=1; startOfStream=1}
Pipeline state change: stopped
NEW SOURCE: Playlist
ZoneHandler::Run received presetinfo
ZoneHandler::TimerZoneUriExpired 2
ZoneHandler::TimerZoneUriExpired count=2, uri=ohu://192.168.0.25:48275
ZoneHandler::Run received presetinfo
ZoneHandler::TimerZoneUriExpired 1
ZoneHandler::TimerZoneUriExpired count=1, uri=ohu://192.168.0.25:48275



Axel
I can start open home-player manually.

I will check the group ownership but will not have access to my Pi for the next few days. Thanks for your help!

Guus
Find all posts by this user
27-08-2016, 09:15 AM (This post was last modified: 27-08-2016 09:38 AM by guussie.)
Post: #37
RE: Raspbian Headless
(23-08-2016 08:29 AM)axelk Wrote:  > I have no ohplayer in /etc/init.d
>
> Could that be the reason?
no, there is no file needed in /etc/init.d. The start is handled by systemd.

Are you able to start openhome as user 'pi' ?
What is returned when you do this ?

Things which are prohibiting the openhome-player start are user pi is not in the audio group (to access the audio device). And my DAC must be turned on and ready to receive the audio stream.

pi@pa2 ~ $ grep audio /etc/group
audio:x:29Tonguei,axelk



This is how it looks on my pi when I start oh-p manually:

pi@pa2 ~ $ /usr/bin/openhome-player
Using Subnet 192.168.0.0
ZoneHandler. SenderZone is PiPlayer-pa2
OHM SENDER DRIVER LATENCY 150
OhmSender::RunMulticast wait
OhmSender::RunUnicast wait
OHM SENDER DRIVER ENABLED 1
OHU sender running on 192.168.0.25:48275
ZoneHandler::Run received presetinfo
OhmSender::RunUnicast go
ZoneHandler::TimerZoneUriExpired 3
ZoneHandler::TimerZoneUriExpired count=3, uri=ohu://192.168.0.25:48275
ConfigAppBase::ConfigAppBase iResourcePrefix: Softplayer
Pipeline state change: buffering
Pipeline state change: buffering
Pipeline report property: MODE {mode=null; supportsLatency=0; realTime=1; supportsNext=0; supportsPrev=0}
Pipeline report property: TRACK {uri=; mode=null; trackId=1; startOfStream=1}
Pipeline state change: stopped
NEW SOURCE: Playlist
ZoneHandler::Run received presetinfo
ZoneHandler::TimerZoneUriExpired 2
ZoneHandler::TimerZoneUriExpired count=2, uri=ohu://192.168.0.25:48275
ZoneHandler::Run received presetinfo
ZoneHandler::TimerZoneUriExpired 1
ZoneHandler::TimerZoneUriExpired count=1, uri=ohu://192.168.0.25:48275



Axel

Hi Axel,

Apparently the problem was not related to permissions.

In oh.service I changed this line:

Code:
ExecStart=-/usr/bin/openhome-player > /dev/null 2>&1

to this:

Code:
ExecStart=-/usr/bin/openhome-player

Now it's working. The Dac is also working perfectly.

The player does not seem to be able to remember the playlist, though.

Thanks for your help!

Guus

I have posted comprehensive instruction for installing the headless version of openhome-player here: install headless openhome-player
Find all posts by this user
27-09-2016, 02:18 AM
Post: #38
RE: Raspbian Headless
Hello Guussie & Axelk!

Many thanks for your comprehensive installation procedure...it was VERY helpful!

I followed the procedure exactly...however something is not working properly for me.

After going through the complete procedure and rebooting, I can't get the Lumin app to recognize the RPi.

If I run...pi@raspberrypi:~ $ sudo systemctl status oh.service

I get something very similar to this...
● oh.service - OpenHome Player
Loaded: loaded (/etc/systemd/system/oh.service; enabled)
Active: active (running) since Fri 2016-07-01 11:11:08 CEST; 6min ago
Main PID: 718 (openhome-player)
CGroup: /system.slice/oh.service
└─718 /usr/bin/openhome-player

If I then use...
pi@raspberrypi:~ $ sudo killall openhome-player

Then reload with...
pi@raspberrypi:~ $ openhome-player

Everything is then working perfectly!

I believe something is wrong with openhome-player start at boot portion of the procedure...however I'm not sure what to check next.

Any suggestions or ideas would be much appreciated.

Many thanks!
Mike
Find all posts by this user
27-09-2016, 11:01 AM
Post: #39
RE: Raspbian Headless
Hi Mike,

I had a similar problem. I solved it by changing the option 'Wait for Network at Boot' to be 'yes' (I think the default is no) in raspi-config.

It looks like the oh.service is being run before the network is fully established, by changing the option it allows the network to settle down before oh.service is run (that's my theory anyway :-))

Thanks,

Pete.
Find all posts by this user
27-09-2016, 01:45 PM
Post: #40
RE: Raspbian Headless
Hi Pete -

I was excited to test your theory this morning because it made sense to me...and I would have never thought of that on my own! You were correct that the 'wait for network to boot' default was 'no' in raspy-config. So I made the change to 'yes'....and waited anxiously for the reboot.

However...upon rebooting the result was the same.
It shows open home-player loaded and active...but the Lumin app can't see it. As usual, if I killall openhome-player then reload it...everything is working very fine.

I feel like we are 99% there...just missing a little step.

Many thanks for your help!
Mike
Find all posts by this user


Forum Jump: